vlc-0.8.1.ebuild
上传用户:riyaled888
上传日期:2009-03-27
资源大小:7338k
文件大小:7k
源码类别:

多媒体

开发平台:

MultiPlatform

  1. ###############################################################################
  2. # vlc.ebuild: A Gentoo ebuild for vlc
  3. ###############################################################################
  4. # Copyright (C) 2003-2004 VideoLAN
  5. # $Id: vlc.ebuild 7593 2004-05-04 20:03:10Z hartman $
  6. #
  7. # Authors: Derk-Jan Hartman <hartman at videolan dot org>
  8. #
  9. # This program is free software; you can redistribute it and/or modify
  10. # it under the terms of the GNU General Public License as published by
  11. # the Free Software Foundation; either version 2 of the License, or
  12. # (at your option) any later version.
  13. # This program is distributed in the hope that it will be useful,
  14. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  15. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
  16. # GNU General Public License for more details.
  17. #
  18. # You should have received a copy of the GNU General Public License
  19. # along with this program; if not, write to the Free Software
  20. # Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA  02111, USA.
  21. ###############################################################################
  22. # Some of the ideas in this ebuild are derived from the official Gentoo ebuild
  23. # Thanks to the Gentoo Team for supporting us.
  24. ###############################################################################
  25. inherit libtool gcc eutils
  26. # Missing support for...
  27. # tarkin - package not in portage yet - experimental
  28. # theora - package not in portage yet - experimental
  29. # tremor - package not in portage yet - experimental
  30. IUSE="arts ncurses dvd gtk nls 3dfx svga fbcon esd X alsa ggi speex
  31.       oggvorbis gnome xv oss sdl aalib slp bidi truetype v4l lirc 
  32.   wxwindows imlib matroska dvb mozilla debug faad
  33.   xosd altivec png dts"
  34. S=${WORKDIR}/${P}
  35. DESCRIPTION="VLC media player - Video player and streamer"
  36. SRC_URI="http://download.videolan.org/pub/${PN}/${PV}/${P}.tar.bz2"
  37. HOMEPAGE="http://www.videolan.org/vlc"
  38. SLOT="0"
  39. LICENSE="GPL-2"
  40. KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~amd64 ~ia64 ~ppc64"
  41. RDEPEND="X? ( virtual/x11 )
  42. aalib? ( >=media-libs/aalib-1.4_rc4-r2 
  43. >=media-libs/libcaca-0.9 )
  44. alsa? ( >=media-libs/alsa-lib-0.9_rc2 )
  45. dvb? ( media-libs/libdvb
  46. media-tv/linuxtv-dvb )
  47. dvd? ( >=media-libs/libdvdread-0.9.4
  48. >=media-libs/libdvdcss-1.2.8
  49. >=media-libs/libdvdnav-0.1.9
  50. >=media-libs/libdvdplay-1.0.1 )
  51. esd? ( >=media-sound/esound-0.2.22 )
  52. faad? ( >=media-libs/faad2-2.0 )
  53. ggi? ( >=media-libs/libggi-2.0_beta3 )
  54. gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
  55. gtk? ( =x11-libs/gtk+-1.2* )
  56. imlib? ( >=media-libs/imlib2-1.0.6 )
  57. lirc? ( app-misc/lirc )
  58. mad? ( media-libs/libmad
  59. media-libs/libid3tag )
  60. matroska? ( >=media-libs/libmatroska-0.7.0 )
  61. mozilla? ( >=net-www/mozilla-1.5 )
  62. ncurses? ( sys-libs/ncurses )
  63. nls? ( >=sys-devel/gettext-0.12.1 )
  64. oggvorbis? ( >=media-libs/libvorbis-1.0.1
  65. >=media-libs/libogg-1.1 )
  66. sdl? ( >=media-libs/libsdl-1.2.5 )
  67. slp? ( >=net-libs/openslp-1.0.10 )
  68. bidi? ( >=dev-libs/fribidi-0.10.4 )
  69. truetype? ( >=media-libs/freetype-2.1.4 )
  70. wxwindows? ( >=x11-libs/wxGTK-2.4.2 )
  71. xosd? ( >=x11-libs/xosd-2.0 )
  72. 3dfx? ( media-libs/glide-v3 )
  73. png? ( >=media-libs/libpng-1.2.5 )
  74. speex? ( >=media-libs/speex-1.1.5 )
  75. dts? ( >=media-libs/libdts-0.0.2 )
  76. svga? ( media-libs/svgalib )
  77. >=media-sound/lame-3.93.1
  78. >=media-libs/libdvbpsi-0.1.3
  79. >=media-libs/a52dec-0.7.4
  80. >=media-libs/libmpeg2-0.4.0
  81. >=media-video/ffmpeg-0.4.8.20040222
  82. >=media-plugins/live-2004.03.05
  83. >=media-libs/flac-1.1.0"
  84. DEPEND="$RDEPEND >=sys-devel/autoconf-2.5.8"
  85. src_unpack() {
  86. unpack ${A}
  87. # Change the location of the glide headers
  88. cd ${S}
  89. sed -i 
  90. -e "s:/usr/include/glide:/usr/include/glide3:" 
  91. -e "s:glide2x:glide3:" 
  92. configure
  93. cd ${S}/modules/video_output
  94. epatch ${FILESDIR}/glide.patch
  95. cd ${S}
  96. }
  97. src_compile(){
  98. # Configure and build VLC
  99. cd ${S}
  100. local myconf
  101. myconf="--disable-mga --enable-flac --with-gnu-ld 
  102. --enable-a52 --enable-dvbpsi --enable-libmpeg2 
  103. --disable-qt --disable-kde --disable-gnome --disable-gtk 
  104. --disable-libcdio --disable-libcddb --disable-vcdx 
  105. --enable-ffmpeg --with-ffmpeg-mp3lame 
  106. --enable-livedotcom --with-livedotcom-tree=/usr/lib/live"
  107.         
  108. # qt, kde, gnome and gtk interfaces are deprecated and in a bad condition
  109.         # the same for mga video, libdv and xvid decoders 
  110. # cddax and vcdx (which depend on libcdio and libcddb) are not ready yet
  111. #--enable-pth GNU Pth support (default disabled)
  112. #--enable-st State Threads (default disabled)
  113. #--enable-gprof gprof profiling (default disabled)
  114. #--enable-cprof cprof profiling (default disabled)
  115. #--enable-mostly-builtin most modules will be built-in (default enabled)
  116. #--disable-optimizations disable compiler optimizations (default disabled)
  117. #--enable-testsuite build test modules (default disabled)
  118. #--disable-plugins make all plugins built-in (default plugins enabled)
  119. use debug && myconf="${myconf} --enable-debug" 
  120. || myconf="${myconf} --enable-release"
  121. (use imlib && use wxwindows) && myconf="${myconf} --enable-skins --enable-skins2"
  122. use mozilla 
  123. && myconf="${myconf} --enable-mozilla 
  124. MOZILLA_CONFIG=/usr/lib/mozilla/mozilla-config 
  125. XPIDL=/usr/bin/xpidl"
  126. # vlc uses its own ultraoptimizaed CXXFLAGS
  127. # and forcing custom ones generally fails building
  128. export CXXFLAGS=""
  129. export CFLAGS=""
  130. export WANT_AUTOCONF_2_5=1
  131. export WANT_AUTOMAKE_1_6=1
  132. # Avoid timestamp skews with autotools
  133. touch configure.ac
  134. touch aclocal.m4
  135. touch configure
  136. touch config.h.in
  137. touch `find . -name Makefile.in`
  138. econf 
  139. $(use_enable nls) 
  140. $(use_enable slp) 
  141. $(use_enable xosd) 
  142. $(use_enable ncurses) 
  143. $(use_enable alsa) 
  144. $(use_enable esd) 
  145. $(use_enable oss) 
  146. $(use_enable ggi) 
  147. $(use_enable sdl) 
  148. $(use_enable mad) 
  149. $(use_enable faad) 
  150. $(use_enable v4l) 
  151. $(use_enable dvd) 
  152. $(use_enable dvd vcd) 
  153. $(use_enable dvdread) 
  154. $(use_enable dvd dvdplay) 
  155. $(use_enable dvd dvdnav) 
  156. $(use_enable dvb) 
  157. $(use_enable dvb pvr) 
  158. $(use_enable joystick) $(use_enable lirc) 
  159. $(use_enable arts) 
  160. $(use_enable oggvorbis ogg) $(use_enable oggvorbis vorbis) 
  161. $(use_enable speex) 
  162. $(use_enable matroska mkv) 
  163. $(use_enable truetype freetype) 
  164. $(use_enable bidi fribidi) 
  165. $(use_enable svga svgalib) 
  166. $(use_enable fbcon fb) 
  167. $(use_enable aalib aa) $(use_enable aalib caca) 
  168. $(use_enable xv xvideo) 
  169. $(use_enable X x11) 
  170. $(use_enable 3dfx glide) 
  171. $(use_enable altivec) 
  172. $(use_enable dts) 
  173. ${myconf} || die "configure of VLC failed"
  174. if [[ $(gcc-major-version) == 2 ]]; then
  175. sed -i -e s:"-fomit-frame-pointer":: vlc-config || die "-fomit-frame-pointer patching failed"
  176. fi
  177. # parallel make doesn't work with our complicated makefile
  178. # this is also the reason as why you shouldn't run autoconf
  179. # or automake yourself. (or bootstrap for that matter)
  180. MAKEOPTS="${MAKEOPTS} -j1"
  181. emake || die "make of VLC failed"
  182. }
  183. src_install() {
  184. einstall || die "make install failed"
  185. dodoc ABOUT-NLS AUTHORS COPYING ChangeLog HACKING INSTALL* 
  186. MAINTAINERS NEWS README* THANKS doc/ChangeLog-*
  187. }